zzz.i2p

Development discussions
 
Wed, 12 Sep 2018, 04:17am #1
mhatta
Contributor

Hello,

I set up a search engine for the I2P network.

http://legwork.i2p

It only indexes eepsites -- no .onions, no clearnet sites.

It already runs several days and works reasonably good (well, sometimes a bit shaky, I admit...)

I prepared this for my research since it seems most of the other search engines have been dead since ca. 2016, but you are more than welcome to use it.

Features:

* YaCy-based
* Only accessible via I2P - so you keep being anonymous and this site cannot get any private information
* The index is updated at least once a day (I am still tweaking the schedule)
* Respects robots.txt
* Support multiple languages

I also cooked up Terms of Service-ish stuff: http://legwork.i2p/AboutDisclaimer.html. I appreciate if you could proofread and improve.

Enjoy,

Tue, 18 Sep 2018, 08:20pm #2
hummingbird
I2P Legend

See also : http://i2pwiki.i2p/index.php?title=YaCy
(any editions are welcome)

Sat, 29 Sep 2018, 12:18pm #3
zzz
Administrator
Zzz

to enable search box in console, add advanced config:

routerconsole.searchEngine=legwork.i2p
routerconsole.searchEngines=legwork.i2p,http://legwork.i2p/yacysearch.html?query=%s
routerconsole.showSearch=true

Sat, 29 Sep 2018, 08:45pm #4
Qubes
I2P Legend

Works very well and is fast too!

Mon, 12 Nov 2018, 09:22pm #5
YesYesYes well maybe
I2P Legend

Thanks!

Tue, 13 Nov 2018, 07:00pm #6
pubcrawlhk@secmail.pro
Contributor

Thanks, already book Mark and backup it , suggest the base32 domain contact list as well

After a few search , the results Change to display one hundred, the language mix with different languages, the data depecated, some eep site was disconnected and request login information to access

As the underground non clean net SEO search engine optimisation

We suggest to hss3uro2fsfq dot onion related that Search engine is much better to counter Google trend and yahoo news

Last edited: Tue, 13 Nov 2018, 07:19pm by pubcrawlhk@secmail.pro


still finding how to use Pretty good privacy certificate generate by GPG4win

Sat, 17 Nov 2018, 02:36am #7
litigatormaster
Lurker

This is a great search engine that actually works and is fast as well. I have been trying to find a decent search engine to lookup certain (sealed) information and/or case laws that are much difficult, or maybe impossible to find on clearnet.

However, after a few days of no luck, I found this thread, and thankfully, I was able to find this: "http://cases.i2p/en/country-united-states-s/";, which does in fact look promising, but I can't seem to find a solution to "The website was not reachable".

If you guys don't mind, I would like to ask you if you can assist me with this issue. I've had my connection (fast/high bandwidth) open for a few hours, with hundreds of peers and tunnels, yet, whenever I click on a specific state or search something within cases.i2p, it takes forever to load then I get the unreachable message referenced above. Assuming the website is functioning properly, so as my router/connection, therefore, what could possibly be the issue here?

Another thing that I have been trying to figure out for the past month without any luck is the grep command in terminal. I figured this is a dev forum, so someone here must know the answer to the following question; I'm trying to search a specific word through 7,800+ files (pdf/doc). To obtain relevant results, I would usually use the command to search the Spotlight database (index) which is mdfind. Out of 7500 case files, mdfind picked those 40 or so which contained one certain word. As you probably know, mdfind is the backend of Spotlight search, which means that spotlight must index the system before displaying any relevant results.

What I'm trying to accomplish is to find a way to use grep/find/locate that would function as mdfind, but without "indexing" the system. Our network has about 6 shared drives and 4 users with access to those drives. So its very difficult to index such a large database with over 8 TB and 80,000+ pdf/doc files. If, for example, I want to find all files pertaining to a client with last name Kennedy, I use "mdfind kennedy" with return results such as:
/Volumes/Net01/Users/Civil Lit/Documents/E. Qualified Private Benefits.pdf
/Volumes/USB-Backup1/Users/Ed****/Cases/07-2445_23-.doc
/Users/Sam****/Downloads/Stats-Review.docx
/Users/Sam****/DownloadsRecent/Stats-Review.docx

Would you kindly recommend a better way to search those words (or names) in pdf/word files throughout multiple drives/folders, that would generate better results than mdfind? I have tried to run the commands below without any success, either the output results didn't match the keyword or displayed no results at all.
Running GNU grep 3.1 on OSX
grep -wirl "word" ./*
grep -wirln "word" ./*.pdf
grep -rlEwi "word" ./
find . | grep "word"

Any help would be much appreciate it.

Sat, 29 Dec 2018, 10:38am #8
mhatta
Contributor

Thank you for using legwork.i2p. I updated the OS and I2P (now 0.9.37) on the machine I run it. I guess it works, but please let me know if you experience any problem.

BTW, legwork.i2p currently indexes over 60,000 documents.