zzz.i2p

Development discussions
Orchid 1.2.2-0.3 « Plugins « I2P Development
 
Sun, 15 Apr 2018, 04:10pm #1
zzz
Administrator
Zzz

This is a major update over 1.2.2-0.2, which was released in August 2016. Tor protocol changes caused the plugin to stop working at all. See ticket #2079 http://trac.i2p2.i2p/ticket/2079 for details.

Sorry for the delay. I did what I could in November 2017, I had partial changes, but it still didn't work. As it turns out, there was no fix posted on github until about two months ago. Thanks to mhatta for his help figuring this out.

- Reduce max consensus age again (ticket #1220)
- Don't load a cached-microdesc from disk that is too old (ticket #1937)
- Update dirauths (ticket #2079)
- Fix spurious errors at shutdown (ticket #2079)
- Fix for new certificate types in tor-spec 4.2 (ticket #2079)

Note that there are still startup problems if you haven't run the plugin in a long time - tickets #1220 #1937. For me, the first time I ran the new version, it never finished sTARTING phase after I waited 10 minutes (monitor on the /orchid/ page in the console). I stopped and restarted the plugin (on /configplugins) and it immediately completed startup (/orchid/ page shows RUNNING).

But hey, it's better than it was. Please report results here or on trac.

You may download the plugin for the first time at http://stats.i2p/i2p/plugins/ or if you already have it installed, just click the update button on /configplugins in your console.

Last edited: Tue, 24 Apr 2018, 03:42pm by zzz

Mon, 23 Apr 2018, 11:15am #2
Qubes
I2P Legend

Very good and highly recommended (Orchid)!

It separated very well Tor circuits from TBB and other tor routers.

Minor snags with some proxy sites but most likely MITM.
1. (try proxy through Startpage.com for example, no problems through Searx.me)
2. (one certificate from i2pd Supervillan repo was deemed unsecured through Orchid but fingerprinted OK through notary convergence and Gibson Research sha1)

I do not like reporting snags because it gives the wrong impression. Again add on highly recommended.

Unrelated to Orchid:

1. i2p Control Add On still colapses bandwidth to almost 0 (appears harmonics) in about 15-30 minutes.

2. If you are using FF nightly, add Luminous (FF add on) and you will get rid of most of the i2p injections attacks. If you are not under attack continuously and i2p works fast no need for it.

Tue, 24 Apr 2018, 01:23pm #3
thebland
I2P Legend

zzz

Can confirm the continuing issue with startup of Orchid. I had two situations I tried.

1. Updated plugin from old version.
a. Orchid plugin stayed stuck at Starting. Stopped and started plugin. No joy.
b. Deleted files from the Orchid plugin "data" directory as the cached-microdesc, states, certs, etc were all old and restarted plugin. No joy.
c. Deleted plugin and reinstalled from http://stats.i2p/i2p/plugins. After 5-10 minutes it finally changed status to Running in the Orchid console.

2. Delete old plugin and download new from http://stats.i2p/i2p/plugins
a. That seems to work better and it went to Running status after a short time.

I cannot say for sure that if I had waited longer with situation 1 that Orchid may have started working. Other than the startup, Orchid looks to back in order as web and .onions that I tried were reachable.

Thank you again for getting this running as I prefer it to the i2p out-proxy.

thebland

Tue, 24 Apr 2018, 02:09pm #4
Qubes
I2P Legend

An OLD trick to see if the i2prouter is corrupted.
1. Download and verify the new version.
2. Install in a new directory IPP or i3p or whatever you like.
3. Shut down old router and start the new install

cd ipp
firejail ./i2prouter start

check if everything is working as it should

I rarely allow an update stay for more than 24 hours on any JAVA program! If you are using a repo it is more complicated but not brain surgery.

I would try the new version of the add on from scratch. If that does not work, reinstall Java and if that does not work run rootkits and file a bug.

Tue, 24 Apr 2018, 03:42pm #5
zzz
Administrator
Zzz

Thanks for the feedback. Obviously it still has problems.

mhatta knows the most about it as he's actually been reading the Tor specs (I haven't). He told me sometimes it takes up to 20-30 minutes but will eventually start. I haven't waited that long. Of course it shouldn't be that way... for further research...

Thu, 26 Apr 2018, 01:15pm #6
Qubes
I2P Legend

This is unacceptable to me! This is why this project is in Java and not some other programming language!

If you have the following:
headless install, JDK 1.8 it should work!

i2prouter MD5 aa48fe7631a77d6202b3f48f42e5fc08
orchid.su3 MD5 e97b6085fdca75af9b270b130b99783c

Please post MD5 of installed files that should be the same for everybody.

Wed, 06 Jun 2018, 10:23pm #7
Maverick_US
Lurker

I am also having a problem getting my plugin to function. It has been running for 11 days straight and has not started yet. It was working fine on my ODroid XU4 running Ubuntu MATE 16.04. I wiped it out and did a fresh install of Ubuntu MATE 18.04, and let it sit for 11 days and it never started

I rebooted yesterday, and now it says.

Plugin Status
Status is: STARTING
Registered? false
Circuit Status
Configuration
Config Value
Bridges []
Circuit Build Timeout 60000
Circuit Idle Timeout 3600000
Circuit Stream Timeout 0
Client Reject Internal Address true
Enforce Distinct Subnets true
Entry Guards 3
Entry Nodes []
Exclude Exit Nodes []
Exclude Nodes []
Exit Nodes []
Fascist Firewall false
Firewall Ports [80, 443]
Handshake V2 Enabled true
Handshake V3 Enabled true
Long Lived Ports [21, 22, 706, 1863, 5050, 5190, 5222, 5223, 6523, 6667, 6697, 8300]
Max Circuit Dirtiness 600000
Max Client Circuits Pending 32
New Circuit Period 30000
Safe Logging true
Safe Socks false
Strict Nodes false
Use Bridges false
Use Microdescriptors AUTO
Use NTor Handshake AUTO
Warn Unsafe Socks true

-----------------------------------------------------------------------------------------
Version according to console.
Version: 0.9.34-0-1ubuntu3-1ubuntu3
Uptime: 30 hours
Clock Skew: −16 ms
Memory: 148 / 256 MiB
----------------------
md5deep -zt /usr/bin/i2prouter
70148 493ea07e3d48f18db7ba6bffaf699b7b 2018:05:22:06:40:40 /usr/bin/i2prouter
md5deep -ztr orchid
604 3948bec9502cbc294c0f82369075a971 2018:05:22:09:48:31 /home/user/.i2p/plugins/orchid/plugin.config
186 d5469f148d0c38ece506d3d2404b3990 2018:05:22:09:48:30 /home/user/.i2p/plugins/orchid/clients.config
580 6f1ac21f93d3603e33587890ee6b151e 2018:05:22:10:07:43 /home/user/.i2p/plugins/orchid/orchid.config
110150 3e23a2ef1637f30c17a9335a78dcb886 2018:05:22:09:48:30 /home/user/.i2p/plugins/orchid/lib/xmlrpc-common.jar
8692 acf74aec8b524c08c151078787393299 2018:05:22:09:48:30 /home/user/.i2p/plugins/orchid/console/webapps/orchid.war
109 a83d3bb72835baa570540183d7b71fe0 2018:05:22:09:48:30 /home/user/.i2p/plugins/orchid/console/webapps.config
58936 ce1e86cc9828928501d75fdd35104777 2018:05:22:09:48:30 /home/user/.i2p/plugins/orchid/lib/xmlrpc-client.jar
132 3fa9cac713bd885db829e7f6fa4abd77 2018:05:22:09:48:30 /home/user/.i2p/plugins/orchid/README.txt
57 f7bc2aa95c92ff88a32190cc445b2cfe 2018:05:22:09:48:30 /home/user/.i2p/plugins/orchid/LICENSE.txt
107 9487ebcc31d3734c793e30f43a847632 2018:05:22:09:48:31 /home/user/.i2p/plugins/orchid/licenses/LICENSE-Orchid.txt
11560 d273d63619c9aeaf15cdaf76422c4f87 2018:05:22:09:48:31 /home/user/.i2p/plugins/orchid/licenses/LICENSE-xmlrpc.txt
168 c32994771b018229c669c7ba218233ee 2018:05:22:09:48:31 /home/user/.i2p/plugins/orchid/licenses/NOTICE.txt
530677 487398cf1b607e8750d61e6af83d53b4 2018:05:22:09:48:31 /home/user/.i2p/plugins/orchid/lib/orchid.jar
-----------------------------------------------------------------------------------------
Above is the MD5 hashes of the plugin files and the ip2router file.

Sun, 24 Jun 2018, 06:45pm #8
Qubes
I2P Legend

All the Norway sites have problems. From geti2p to meeh (orchid). I do check them at least once a week. (Downloading i2p from geti2p.net is notoriously a problem if you have good security and anonimity.)
Orchid should not take more than 15 minutes to start. At this time mine is down too. Disregard the messages unless you want to debug. I can see that some cookies are getting through Orchid (searx.me) but not the full site. It is a good idea not to have any i2p sites connected when you are using Orchid since it is eating a lot of bandwith.

Give it another try with all your personal i2p activity OFF.

Thu, 11 Oct 2018, 05:03am #9
naemsi
Lurker

Orchid works well until the i2p node is restarted. Then it doesn't work at all (permanent STARTING) until it is removed and reinstalled. Then it works well again. :-) Is there a way to gather more information on this failure mode?

Wed, 16 Jan 2019, 03:45pm #10
zzz
Administrator
Zzz

Version 1.2.2-0.4 released to fix the above issues, as documented in ticket 2079.