zzz.i2p

Development discussions
Last call: Java 7, Wheezy, Jessie, Precise, Trusty « Big Topics, Ideas, Proposals and Discussion « I2P Development
 
Fri, 28 Feb 2020, 05:55pm #1
zzz
Administrator
Zzz

The next I2P release 0.9.46 will be the last one that supports Java 7.

This means we will not have any newer official packages in our PPA or Debian repo for Wheezy, Jessie, Precise (12.04), and Trusty (14.04) after 0.9.46.

Anybody still on Java 7, Wheezy, Jessie, Precise, or Trusty will not be able to install with our official installers, and will not be able to automatically update.

You may still be able to build it yourself, if you have the required backport packages.

This is driven by minimum JRE requirements for our package dependencies, in particular Jetty. Certain portions of our source code will remain Java 6 or 7 compatible because of Android.

Please ensure you have updated to Java 8 or higher, and/or Debian Stretch or higher, and/or Ubuntu Xenial (16.04) or higher to continue receiving I2P updates.

Last edited: Fri, 10 Apr 2020, 07:22pm by zzz

Fri, 10 Apr 2020, 07:11pm #2
zzz
Administrator
Zzz

Still on track that 0.9.46 will be the last release for Java 7 and the above distros. See tickets #2098 and #2511.